WordPress.org

About

Requirements

आवश्यकताहरू

To run WordPress, it’s recommended your host supports:

That’s really it. Apache or Nginx is recommended as the most robust and featureful server for running WordPress, but any server that supports PHP and MySQL will do. That said, for the smoothest experience in setting up—and running—your site, each host on the hosting page supports the above and more with no problems.

विस्तृत पिएचपी एक्सटेन्सन सिफारिसहरूको लागि होस्टिङ ह्यान्डबुक हेर्नुहोस्।

Note: If you are in a legacy environment where you only have older PHP or MySQL versions, WordPress also works with PHP 7.0+ and MySQL 5.5.5+. However, these versions have reached their official End Of Life and may expose your site to security vulnerabilities.

Ask your host to run WordPress

If you’re unsure whether or not your host can already run WordPress, here’s a request you can copy and paste to send them!

I’m interested in running the open source WordPress <https://wordpress.org/> web software, and I was wondering if my account supported the following:

  • पिएचपी 7.4 वा उच्च
  • माइएसक्युएल 8.0 वा उच्च अथवा मरियाडिबी 10.4 वा उच्च
  • इन्जिनएक्स वा अपाचे mod_rewrite मोड्युलको साथ
  • एचटिटिपिएस समर्थन

धन्यवाद!

आवश्यक छैन, तर राम्रो सुरक्षाको लागि सिफारिस गरिएको छ

होस्टिङ अधिक सुरक्षित हुन्छ जब पिएचपी एप्लिकेसनहरू, जस्तै वर्डप्रेस, सर्भरको पूर्वनिर्धारित साझा युजरनेमको सट्टा तपाईँको खाताको युजरनेम प्रयोग गरी सञ्चालन गरिन्छ। तपाईँको सम्भावित होस्टलाई सोध्नुहोस् कि उनीहरूले तपाईँको खाताको सुरक्षा सुनिश्चित गर्न के कदम चाल्छन्।