Play Audio Once

विवरण

Adds an option to the audio block in Gutenberg-editor to prevent the file from being played multiple times.

In the frontend, the option, if activated, is executed on the audio file if the visitor’s browser has JavaScript activated. The fact that an audio file was played is saved in the browser session – not as a cookie. The storage takes place at the moment of playback, which means that it is no longer possible to rewind or fast-forward. The user is not offered an option to reset.

GitHub

The source-code of this plugin is hosted on GitHub.

स्थापना

  1. Upload “play-audio-once” to the “/wp-content/plugins/” directory.
  2. Activate the plugin through the “Plugins” menu in WordPress.
  3. Choose the newly added option on any audio-block in your project.

समीक्षाहरू

मार्च 5, 2022
I needed a way to play an mp3 clip for a student who would then answer one or more questions. It was very important that the clip could only be played once to prevent the student from playing the clip over and over again before answering the questions. This plugin does exactly that. It’s incredibly easy to implement and has been “bullet proof”. Thanks and thanks again!
सबै 1 समीक्षा पढ्नुहोस्

योगदानकर्ता र डेभलपरहरू

“Play Audio Once” खुला स्रोत सफ्टवेयर हो। निम्न व्यक्तिहरूले यो प्लगिनमा योगदान गरेका छन्।

योगदानकर्ताहरू

“Play Audio Once” 2 लोकेलहरूमा अनुवाद गरिएका छन्। योगदानको लागि अनुवादकहरूलाई धन्यवाद।

“Play Audio Once” लाई आफ्नो भाषामा अनुवाद गर्नुहोस्

विकासमा रुचि छ?

आरएसएस द्वारा कोड ब्राउज गर्नुहोस्, एसभीएन रिपजिटरी हेर्नुहोस्, वा विकास लग को सदस्यता लिनुहोस्।

चेन्जलग

1.0.0

  • Initial commit

1.0.1

  • Updated dependencies

1.0.2

  • Updated compatibility-flag for WordPress 6.0

1.0.3

  • Updated compatibility-flag for WordPress 6.0.1
  • Added build-system in repository

1.1.0

  • Added translations for german (formal), spanisch and italian
  • Fixed setting of default value for our plugin-option
  • Updated compatibility-flag for WordPress 6.2
  • Updated dependencies
  • Cleanup repository

1.1.1

  • Optimized translation-handling during plugin-build
  • Compatible with WordPress Coding Standards
  • Updated compatibility-flag for WordPress 6.3
  • Updated dependencies

1.1.2

  • Updated compatibility-flag for WordPress 6.4
  • Updated dependencies
  • Compatible with WordPress Coding Standards 3.0

1.1.3

  • Removed language files from release
  • Cleaned js-files
  • Updated dependencies (security fixes in them)

1.1.4

  • Updated compatibility-flag for WordPress 6.5
  • Updated dependencies (security fixes in them)